I Am Joe’s Blog:

February 21, 2008 • 4:29 PM

SuperDuper 2.5 Released with Leopard Compatibility

New TidBITS article: SuperDuper 2.5 Released with Leopard Compatibility (2008-02-21)